~Hilltop Farm Forum~

Anything and Everything Poultry, Small Animals, Livestock, Gardening and more. Chickens, Eggs, Cattle, Goats, Sheep, Horses, Pets, etc. For Sale And Want Ads. Register - Login - And Come On In - Post Your comments or, Or Just Chat!

You are not logged in.

Announcement

Welcome to ~Hilltop Farm Forum~
Click for events ---> Buy/Sell/Swap/Trade/Shows/Events Click for listings ---> Chicken Swap of Florida
Facebook, Florida Farm Swap Meets (Georgia too now)
Rose Comb Rhode Island White facebook page

Adverts

Adverts

#1 October-3-2017 2:02:pm

JoeClark
quite a regular
Registered: September-11-2017
Posts: 35
Reputation :   

Questions about Sound

I am trying to add sound to a number of Winbuttons so that they click when pressed. In the button's event, I am specifying a sound to be played, but I also want the event passed along to my host application. This works fine for normal buttons, except that it always passes along the number of the sound file that is played instead of the status of the button. So for a latching (push on/push off) button, I have no way of telling if the button is on or off. Is there some way to activate the sound, but still get the current state of the button when it is pressed? I don't want to send a separate message to create the sound because it adds another level of complexity to the host code.

Second question: When I add sound files, they keep getting re-arranged instead of staying in the order I added them. Also, the sound played doesn't correspond to the index shown in the Sound object's list, so I have to use trial and error to determine which sound is going to play for any given index. Is this a bug or am I missing something?


Thank You!!!

I didn't find the right solution from the Internet.
References
http://forum.4dsystems.com.au/forum/for … bout-sound
Medical Device Marketing

Offline

 

October-3-2017 2:02:pm

AdBot
Advertisements

Adverts

Board footer

Powered by FluxBB
Hosted by PunBB-Hosting